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Introduction

Stingray Document Aligner
Stingray is a cross-platform document aligner designed to assist professional translators in the production of
translation memories from existing translated material.

Translation memories generated by Stingray can be used in most modern CAT (Computer Aided Translation)
tools, including Swordfish.

Supported File Formats
The file formats currently supported by Stingray are:

Software Development TypesGeneral Documentation Types

• JavaScript• Adobe InDesign Interchange (INX)

• Adobe InDesign IDML CS4, CS5, CS6 & CC • Java Properties

• PO (Portable Objects)• HTML

• Microsoft Office 2007/2008/2010/2011/2013/2016 • RC (Windows C/C++ Resources)

• ResX (Windows .NET Resources)• Microsoft Visio XML Drawings 2007/2010/2013

• MIF (Maker Interchange Format) • TS (Qt Linguist translation source)

• OpenOffice/LibreOffice/StarOffice 1.x/2.x/3.x/4.x/5.x

• Plain Text

• RTF (Rich Text Format)

• XML (Generic)

• XML with ready to use configuration files for:

– DITA 1.0, 1.1 and 1.2

– DocBook 3.x, 4.x and 5.x

– SVG

– Word 2003 ML

– XHTML

The filter for XML files supports custom configuration. Users can define conversion rules for almost any XML
vocabulary.

Supported Platforms
• Microsoft Windows (7, 8, 8.1 and 10)

• macOS (10.10, 10.11, 10.12, 10.13 and 10.14)

• Linux (with GNOME Desktop Manager)
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Aligning Documents

Alignment Process
Aligning is a process with 3 basic steps:

1. Create a project, selecting the documents to align or importing a TMX file.

2. Correct the alignment of the generated/imported segment pairs.

3. Export the aligned segments to a useful file format.

Step 1: Create a project
An alignment project can be created in two ways:

1. Processing two documents with similar structure to extract segment pairs. Use this option to create a new
translation memory from a document and its translation.

2. Importing a TMX file. Use this option to correct the content of segments already defined by a translation tool.

Generate a project from two documents

Procedure

1. In the File menu, select New Alignment Project or click the  button.

The following dialog appears:

2. Enter the name of the alignment project file in the Project File text box or use the Browse... button next to
it to select a name and location.

3. Select a source file and configure its properties in the Source File panel.
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Type the name of the source file in the File text box or use the Browse... button next to it to select a file
from the operating system. If you use the Browse... button, the programs tries to automatically detect
document type and character set.

a.

b. Select or correct the type of document in the File Type drop-down list.
c. Select or correct the character set of the document in the Character Set drop-down list.

4. Select the file that contains the translations and configure its properties in the Translation panel.

a. Type the name of the translation file in the File text box or use the Browse... button next to it to select
a file from the operating system. If you use the Browse... button, the programs tries to automatically
detect document type and character set.

b. Select or correct the type of document in the File Type drop-down list.
c. Select or correct the character set of the document in the Character Set drop-down list.

5. If you want to align paragraphs instead of sentences, check the Paragraph Segmentation box.

6. If you are processing plain text documents, verify their formatting and check the Break Segment on Every
CR/LF (Plain Text) box .

7. Enter the name of the SRX file to use for segmenting the documents in the SRX Rules text box or use the
Browse... button next to it to select an SRX file from the file system.

8. Click the Align Files button to create the project and display it in Stingray's main panel.

Generate a project from a TMX file

Procedure

1. In the File menu, select Import TMX File.

The following dialog appears:

2. Type the name of the TMX file to import in the TMX File text box or use the Browse... button next to it to
select it from the file system.

3. Type the name of the alignment project to create in the Alignment Project text box or use the Browse...
button next to it to select a name and location.

4. Click th Accept button to start creating the project.

• If the selected TMX file does not have a defined source language, select it in the window that appears.

• If the selected TMX file contains translations in more than two languages, select the target language in
the window that appears.
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Results

A new alignment project is created from the data present in the selected TMX file.

Step 2: Align extracted segments

Procedure

1. Use the buttons that appear below the alignment panel (the columns of text boxes), or their equivalent entries
from the Edit menu, to correct the segments.

• Use the Move Segment Up ( ) and Move Segment Down ( ) buttons to move the segments up and
down until they match the corresponding source/translation in the other column.

• Use the Split Segment button ( ) to split the text in the source or translation text box to match the
counterpart in the other column.

• Use the Merge with Next Segment button ( ) to combine the text in the source or translation text box
with the text of the following segment.

• Use the Delete Segment button ( ) to delete the selected source or translation segment.

• To edit the content of the source or translation text box, click the Edit Segment button ( ) and modify

the text. Save your changes with the Accept Changes button ( ) or discard them using the Discard

Changes button ( ).

Step 3: Export aligned segments
Stingray can export aligned segments in four formats accepted by most translation tools:

• TMX 1.4

• CSV (Comma Separated Values)

• Trados TXT (7.x/8.x)

• XLIFF 1.2

Export as TMX

Procedure

1. In the File menu, select Open File or click the  button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as TMX.
4. Select a file name and location for storing the generated TMX file.

Results

A TMX file is generated and saved in the selected location.

Export as CSV

Procedure

1. In the File menu, select Open File or click the  button.
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2. Locate and open the alignment project to be exported.

3. In the File menu, select Export Alignment Project as CSV.

4. Select the CSV file to generate.

The following dialog appears:

5. Type or select the column separator to use in the Column Separator drop-down list.

6. Type or select the text delimiter to use in the Text Delimiter drop-down list.

7. Select the character set to use in the Character Set drop-down list.

8. Click the Set CSV Options button.

Results

A delimited text file with the specified properties is created and saved in the selected location.

Export as Trados TXT

Procedure

1. In the File menu, select Open File or click the  button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as TXT (Trados 7.x/8x).
4. Select a file name and location for storing the generated TXT file.

Results

A TXT file for Trados 7.x/8x is generated and saved in the selected location.

Export as XLIFF

Procedure

1. In the File menu, select Open File or click the  button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as XLIFF.
4. Select a file name and location for storing the generated XLIFF file.

Results

An XLIFF 1.2 file is generated and saved in the selected location.
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Editing TMX Files

Using Stingray as TMX Editor
Stingray can be used to edit existing TMX files, without aligning two documents.

The steps for editing bilingual TMX files using Stingray are:

1. Import the TMX file into an Alignment Project;

2. Make changes in the imported TMX file;

3. Export the Alignment project as TMX or a different format.

Important: all comments and properties stored in the TMX file are ignored when it is imported into an Alignment
Project.

Import TMX File

Procedure

1. In the File menu, select Open File or click the  button.

2. Locate and open the TMX file to be imported.

The following dialog appears:

3. In the Import TMX File dialog, verify the name of the TMX File and adjust the name and location of the
Alignment Project to be generated.

4. In the Import TMX File dialog, click the Import TMX File button to start the import process.

5. If the selected TMX file does not have a predefined source language, the following dialog will appear:

a. In the Language Selection dialog, select the source language for the Alignment Project from the Source
Language drop-down list.

b. In the Language Selection dialog, click the Select Language button.
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6. If the selected TMX file contains data in more than two languages, the following dialog will appear:

a. In the Language Selection dialog, select the target language for the Alignment Project from the Target
Language drop-down list.

b. In the Language Selection dialog, click the Select Language button.

Results

The selected TMX file is imported into an Alignment Project and opened in Stingray for editing.

Editing a TMX File

In addition to correcting alignment, as shown in section Align Extracted Segments, you can also perform the fol-
lowing common tasks:

• Remove all tags

• Remove Duplicate Entries

• Remove initial and trailing spaces

• Change Language Codes

All features listed above are available in Tasks menu.
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User Interface

Stingray GUI
The following picture portrays Stingray:

Menus

File Menu

Create a new alignment project.New Alignment Pro-
ject

Open an existing alignment project for editing.Open Alignment Pro-
ject

Close current open document.Close Alignment Pro-
ject

Save current open document.Save Alignment Pro-
ject

Save current open document under a new name.Save Alignment Pro-
ject As...

Export aligned segments to a TMX 1.4 file for use in most CAT tools.Export Alignment
Project as TMX
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Export aligned segments to a CSV (Comma Separated Values) file.Export Alignment
Project as CSV

Export aligned segments to a TXT file suitable for use in Trados 7.x/8.xExport Alignment
Project as TXT (Tra-
dos 7.x/8.x)

Export aligned segments to an XLIFF 1.2 file.Export Alignment
Project as XLIFF

Import a TMX file for editing in a new alignment project.Import TMX File

View aligned segments in a web browser.Preview as HTML

Close the program.Exit

Edit Menu

Open a dialog for searching/replacing text in source or translations.Search/Replace

Move selected source segment up one row.Move Source Segment
Up

Move selected source segment down one row.Move Source Segment
Down

Split source segment at current cursor position.Split Source Segment

Combine current source segment with the following one.Merge Source Seg-
ment with Next

Remove source segment from list.Remove Source Seg-
ment

Set source segment as editable to modify its content.Edit Source Segment

Save changes done to source segment.Save Changes to
Source Segment

Discard the changes done to source segment and restore previous content.Discard Changes to
Source Segment

Move selected translation segment up one row.Move Translation
Segment Up

Move selected translation segment down one row.Move Translation
Segment Down

Split translation segment at current cursor position.Split Translation Seg-
ment

Combine current translation segment with the following one.Merge Translation
Segment with Next

Remove translation segment from list.Remove Translation
Segment
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Set translation segment as editable to modify its content.Edit Translation Seg-
ment

Save changes done to translation segment.Save Changes to
Translation Segment

Discard the changes done to the translation segment and restore its previous content.Discard Changes to
Translation Segment

Go To Menu

Display the previous segment.Previous Segment

Display the next segment.Next Segment

Display the first segment of the file.First Segment

Display the last segment of the file.Last Segment

Display a segment specified by its number.Got to segment...

Tasks Menu

Remove markup information from all segments.Remove all Tags

Remove all duplicated segments from the alignment project.Remove Duplicate
Entries

Remove leading and trailing spaces from all segments.Remove Initial/Trail-
ing Spaces

Display a dialog for changing source or target languages in the current alignment
project.

Change Language
Codes

Help Menu

Display Stingray User Guide in the default PDF viewer.Stingray Help

Display a dialog for licensing the program.License Management

Verify the availability of newer versions of the program.Check for Updates

Display a dialog with license status and program version information.About...
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License Management

License Keys
A License Key is a short text code required to continue using the application after the 30 days evaluation period.

License Keys can be purchased at http://www.maxprograms.com/store/buy.html

Note

• Registering or disabling a License Key requires an Internet connection.

• Always disable your license key before reformatting your hard disk or changing operating system.

Request an Evaluation License

About this task

You can evaluate the program for free during 30 days before purchasing a License Key. All features are enabled
during the evaluation period.

Procedure

1. When you start the program for the first time, the following dialog appears:

2. If your computer uses a proxy server to connect to the Internet, follow these steps to configure the proxy
server settings:

a. Click the Proxy Settings button.

The following dialog appears:

b. Type the proxy server name or IP in the Server text box.
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c. Type the proxy port number in the Port text box.

d. If your proxy server requires authentication, type the proxy user name in the User ID text box and the
corresponding password in the Password text box.

e. Click the Save Settings button.

Selected proxy settings are saved and the dialog closes.

3. Click the Request Evaluation License button.

The following dialog appears:

4. Type your first name in the First Name text box.

5. Type your last name in the Last Name text box.

6. Enter your company name in the Company text box. This step is optional.

7. Type your email address in the Email text box.

8. Type again your email addres in the Repeat Email text box.

9. Click the Request Evaluation License button.

Your evaluation license request is sent to the Registration Server. An email with an evaluation license key
will be immediately sent to the indicated email address.

10. Check your email and note the new evaluation license key. Check your spam filter if you don't receive an
email with the evaluation license key within a few minutes.

11. Enter the evaluation license in the Licence Key text box of the License Management dialog.

12. Click the Register License button.

Results

Your computer is enabled to work with the application for 30 days.

Register a License Key

Procedure

1. When you start the program after the trial period has ended, after installing an upgrade or after disabling a
License Key, the following dialog appears:
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2. If you need to purchase a License Key, click the Buy License button to open Maxprograms' Online Store in
your browser.

3. Type your license code in the License Key text box.

4. If your computer uses a proxy server to connect to the Internet, follow these steps to configure the proxy
server settings:

a. Click the Proxy Settings button.

The following dialog appears:

b. Type the proxy server name or IP in the Server text box.

c. Type the proxy port number in the Port text box.

d. If your proxy server requires authentication, type the proxy user name in the User ID text box and the
corresponding password in the Password text box.

e. Click the Save Settings button.

5. Click the Register License button.

Results

Your license key code is sent to the Registration Server and your computer is enabled to work with the registered
application.

Disable a License Key

Procedure

1. In the Help menu, select License Management.

The following dialog appears:
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2. If your computer uses a proxy server to connect to the Internet, follow these steps to configure the proxy
server settings:

a. Click the Proxy Settings button.

The following dialog appears:

b. Type the proxy server name or IP in the Server text box.

c. Type the proxy port number in the Port text box.

d. If your proxy server requires authentication, type the proxy user name in the User ID text box and the
corresponding password in the Password text box.

e. Click the Save Settings button.

3. Click the Disable License button.

Results

Your license key code is sent to the Registration Server and the application becomes disabled.

Transfer a License Key
Steps for transferring a working license key to a different computer.

Procedure

1. Start the application in the computer where it is enabled.
2. Disable the license key.
3. Start the application in the computer that you want to use next.
4. Enable the license key.

Results

Your license key is transfered from one computer to another.

14License Management

Stingray User Guide



Configuration Options

Program Settings
Stingray default settings can be changed in the Preferences dialog.

• To open the Preferences dialog on Windows or Linux, select Preferences in Settings menu.

• To open the Preferences dialog on Mac OS X, select Preferences in Apple menu.

Basic Settings
In Preferences dialog, select the Basic tab. The dialog will look like this:

Font Settings

Procedure

1. In the Preferences dialog, select the Basic tab.
2. Click the Change Default Font button.
3. In the font selection dialog, choose the default font, font style and font size to be used by the application.

Results

Selected font will be used by the application to display text in relevant places.

Color Settings

Procedure

1. In the Preferences dialog, select the Basic tab.
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2. Locate the element that you want to modify and enter the RGB values for the desired color in the text box or
click the Select... button to choose a new color using the default color selector widget from the operating
system.

3. Repeat previous step until all colors have been adjusted.
4. Click the Save Colors button to save your changes.

Auto-Save Settings

About this task

The program has the ability to automatically make a backup of the file that is open at a selected interval. Follow
these steps to configure the automatic backup settings.

Procedure

1. In the Preferences dialog, select the Basic tab.
2. Check the Enable Auto-Save box if you want to make automatic backups. Clear it otherwise.
3. Enter the number of seconds to wait between backups in the Interval (Seconds) text box.
4. Click the Save Settings button.

Shortcuts Configuration

Procedure

1. In Preferences dialog, select the Shortcuts tab.

2. Use the scroll bar on the right side to locate the command that you want to modify.

3. Check the boxes for the modifier keys (Alt, Ctrl, Cmd or Shift) required in the new or modified shortcut.

4. Type a character or select a standard key in the drop-down-list on the right.

5. Reapeat the previous 3 steps until all keyboard shortcuts have been configured as desired.
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6. Click the Save Shortcuts button to save your changes or click the Load Defaults button to restore factory
settings and restart the configuration task.

Results

The requested changes are stored in the configuration file and become effective the next time the program is started.

XML Filter Configuration
The program needs to know two things for working with XML files:

• How to locate the grammar rules and entities declared in an XML file, if any.

• What elements and attributes contain translatable text.

XML catalogs that follow the specification published at http://www.oasis-open.org/committees/entity/spec-2001-
08-06.html by OASIS are used to resolve the location of XML DTDs and Schemas.

Special XML files are used to configure the elements and attributes that contain translatable text. These files are
used by the internal XML Converter to extract text for processing. The configuration files are created and maintained
using the application's graphical user interface.

In the Preferences dialog, select the XML Options tab. The dialog will look like this:

XML Converter

Support for the following XML vocabularies is included in the application:

• DITA 1.0, 1.1 and 1.2

• DocBook 3.x, 4.x and 5.x

• Microsoft Office 2007, 2008, 2011, 2013 and 2016

• Microsoft Visio 2010 and 2013

• Open Document Format (OpenOffice)
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• SVG

• Word 2003 ML

• XHTML

Additional configurations can be added by the user as required.

Add XML Configuration

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Click the Add Configuration File button.

The following dialog appears:

3. Type the name of the root element of your XML files in the Root Element text box. The name of the root
element is used to name the configuration file.

4. Click the Set Root Element button.

The following dialog appears:

5. Click the Add Element button to add the configuration of an element.

The following dialog appears:
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6. Type the name of the element being added in the Element Name text box.

7. Select the type of element in the Element Type drop-down list. Available types are:

• segment: the selected element starts a new section of translatable text.

• inline: the selected element represents a change in formatting options and does not start a new section
of translatable text.

• ignore: the selected element and its children should be ignored.

8. If the element type is "inline", select the kind of formatting represented by the element in the Inline Type
drop-down list.

9. If the element has translatable attributes, enter their names separated by a ";" in the Translatable Attributes
text box.

10. If white space needs to be preserved when extracting text, select "Yes" in the Keep White Space drop-down
list.

11. Click the Save Element button to save the element configuration.

12. Repeat the previous steps until all required elements have been configured.

Results

A new configuration file for the XML Converter is created.

Edit XML Configuration

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Select the configuration file to edit from the list of available configurations.

3. Click the Edit Configuration File button.

The following dialog appears:
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4. Use the buttons in the DTD Configuration dialog to update the configuration file.

• Use the Add Element button to add a new element to the configuration file.

• Use the Edit Element button to modify the properties of an existing element.

• Use the Remove Element button to delete an element from the configuration file.

5. Repeat the previous step until all elements are properly configured.

Delete XML Configuration

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Select the entry to remove from the configurations list.

3. Click the Remove Configuration File button.

A confirmation dialog appears.

4. Confirm the delete operation.

Results

The selected entry is removed from the list of available configuration files.

XML Catalog

The application includes a default XML catalog with DTDs and XML Schemas for the most relevant localization
formats and supported document types.

Additional DTDs and XML Schemas can be added by the user as needed.

Add Catalog Entry

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Click the Add Catalog Entry button.

The following dialog appears:
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3. Select the appropriate entry type from the list.

4. Click the Set Entry Type button.

5. If the type of the new entry is "PUBLIC", the following dialog appears:

a. Type the public id of the DTD in the Public ID text box.
b. Type the location of the DTD, relative to the catalog, in the URI text box.
c. Click the Save Entry button.

6. If type of the new entry is "SYSTEM", the following dialog appears:

a. Type the name of the DTD or XML Schema in the System ID text box.
b. Type the location of the DTD or XML Schema, relative to the catalog, in the URI text box.
c. Click the Save Entry button.

7. If type of the new entry is "URI", the following dialog appears:
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Type the name of the URI in the URI Name text box.a.
b. Type the location of the corresponding DTD or XML Schema, relative to the catalog, in the URI text

box.
c. Click the Save Entry button.

8. If the type of the new entry is "nextCatalog" a file selection dialog appears. Locate the catalog in the file
system and save it.

Edit Catalog Entry

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Select the entry to modify from the entry list.

3. Click the Configure Catalog Entry button.

A dialog of the appropriate type for editing the selected entry appears.

4. Edit the properties of the entry.

5. Click the Save Entry button to close the properties configuration dialog.

Delete Catalog Entry

Procedure

1. In the Preferences dialog, select the XML Options tab.

2. Select the entry to remove from the entries table.

3. Click the Remove Catalog Entry button.

A confirmation dialog appears.

4. Confirm the delete operation.

Results

The selected entry is removed from the XML catalog.

Language Codes
Standard language codes from BCP47 are used in in all operations.

A list of the most common language codes is included in the program. The list of languages can be customized as
needed.

In the Preferences dialog, select the Languages tab to configure the languages list. The dialog will look like this:
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Add Language

Steps for adding languages to the application

Procedure

1. In the Preferences dialog, select the Languages tab.

2. Click the Add Language button.

The following dialog appears:

3. Type the code for the new entry in the Code text box. The code must be a valid language tag from BCP47.
Language description is automatically displayed when a valid tag is entered.

4. Click the Add Language button.

Results

A new entry is added to the list of working languages.

Delete Language

Steps for removing a language from the list of working languages.
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Procedure

1. In the Preferences dialog, select the Languages tab.
2. Select the entry to delete in the list of language codes.
3. Click the Remove Selected Language button.

Results

The selected entry is removed from the list of working languages.
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Glossary
Computer Aided Translation (CAT)

Computer technology application designed to assist human translators in the translation process.

Character Set
A character set (sometimes referred to as code page) is a collection of characters that are associated with
a sequence of natural numbers in order to facilitate the storage of text in computers and the transmission
of text through telecommunication networks.

CSV
CSV (Comma Separated Values) is a standard file format used to store tabular data.

SRX
Segmentation Rules eXchange (SRX) is an XML-based open standard, published by LISA (Localization
Industry Standards Association), for describing how translation and other language-processing tools
segment text for processing.

TMX
Translation Memory eXchange (TMX) is an open standard originally published by LISA (Localization
Industry Standards Association). The purpose of TMX is to allow easier exchange of translation memory
data between tools and/or translation vendors with little or no loss of critical data during the process.

Translation Memory
Translation Memory (TM) is a language technology that enables the translation of segments (paragraphs,
sentences or phrases) of documents by searching for similar segments in a database and suggesting
matches that are found in the databases as possible translations.
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