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Introduction
TMXEditor is a cross-platform desktop application designed for editing TMX (Translation Memory
eXchange) files on macOS, Linux and Microsoft Windows.

TMXEditor allows editing the content of multilingual TMX files.

Features
With TMXEditor you can:

• Edit segments of your TMX file to correct errors.

• Merge & split TMX files.

• Add and remove languages from a TMX file.

• Change languages in a TMX file.

• Remove duplicates.

• Remove untranslated units.

• Remove inline tags.

• Trim initial and trailing spaces.

• Consolidate translation units when the TMX file has three or more languages.

• Validate TMX files.

• Clean invalid XML characters from a TMX file.

• Convert to TMX format

– Excel files

– CSV or TAB delimited files

– SDLTM files
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• Export TMX files as

– Excel files

– TAB Delimited files

Supported Platforms
TMXEditor works on these Operating Systems:

• Microsoft Windows (8, 8.1, 10 and 11)

• macOS High Sierra (10.13), Mojave (10.14), Catalina (10.15), Big Sur (11.0) andMonterey (12.0)

• Linux (with GNOME Desktop Manager)
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Getting Started
You can use TMXEditor to edit existing TMX files and also to create new TMX files, empty or from
CSV/TAB delimited data.

• Editing an Existing TMX File

• Create New TMX File

• Convert CSV/TAB Delimited to TMX

Editing an Existing File
1. In main menu, select File → Open option ([Ctrol+O] on Windows/Linux, [Cmd+O] on macOS)

or click the button on the top toolbar.

2. Use the dialog that appears to select a TMX file from the file system.

Once the selected TMX file is open, you can:

• Click on any text cell to start editing it. Click outside the cell or press [Alt+Enter] to save your
changes. Press the [ESC] key to cancel your changes.

• To add new units to the TMX file, select Edit → Insert Unit in manmenu or click the button
from the top toolbar.

• To delete one or more units:

1. Select the check box in the leftmost column of the editing grid to mark the units that you
want to remove

2. Select Edit → Delete SelectedUnits inmainmenuor click the button on the top toolbar.

Note
You can use the top-left checkbox to select/deselect all units at once.

• Use the Filter Units option to locate text in the file.

• Use the Sort Units option to display file entries sorted on a selected language.

Aftermaking changes to the TMX file, select File → Save inmainmenu ([Ctrl+S] onWindows/Linux,
[Cmd+S] on macOS) or click the button on the top toolbar to save your modifications.

Create New TMX File
Follow these steps to creaet a new TMX file.

About this task

Procedure
1. In main menu, select File → New File option ([Ctrl+N] on Windows/Linux, [Cmd+N] on macOS)

or click the button from the top toolbar.

The following dialog appears:
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2. Use the Source Language drop-down to select the language of source text.

3. Use the Target Language drop-down to select the target language.

4. Click the Create TMX File button.

A new file is displayed in the editing grid.

5. To add new entries, click on the button on the top toolbar, or select Edit → Insert Unit in
main menu.

6. Edit cells as explained in Editing an Existing File section.

7. To save the changes made to the file, select File → Save option ([Ctrl+S] on Windows/Linux,
[Cmd+S] on macOS) in main menu, or click the button on the top toolbar.

8. Use the dialog that appears to indicate the name and location where the new TMX file will be
saved.
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Maintenance Tasks
TMXEditor maintenance options are

• Maintenance Dashboard.

• Sort TM Units

• Filter Units

• Search & Replace Text

• Change Language

• Add Language

• Remove Language

• Change Source Language

• Remove Inline Tags

• Remove Duplicated Units

• Remove Translation Same as Source

• Remove Initial & Trailing Spaces

• Consolidate Translation Units

• Split TMX File

• Merge TMX Files

Maintenance Dashboard
Follow these steps to optimize a TMX file using a simplified dialog.

About this task
Maintenance Dashboard allows you to perform maintenance tasks in a simplified dialog that
incorporates several actions available in Tasksmenu.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Tasks → Maintenance Dashboard option or click the button on the
top toolbar.

The following dialog appears:
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3. Select the corresponding checkboxes for all tasks that you want to perform:

• Remove All Tags: remove all inline tags from the TMX file.

• Remove Duplicates: remove duplicated translation units.

• Remove Untranslated: remove all untranslated units.

• Remove Initial/Trailing Spaces: remove spaces at the start and end of all language
entries.

• Consolidate Units: merge translation units that share a common source language entry.

4. If you selected Remove Untranslated or Consolidate Units, select the source language of
the TMX file using the Source Language drop-down.

5. Click the Perform Maintenance button.

Results
A maintenance process is started and an indicator is displayed on screen while all selected tasks
are performed.

Sort TM Units
Follow these steps to display the entries of your TMX file sorted on a selected language.

About this task
Data in a TMX file is stored without a particular order. Sometimes it may be useful to sort data
according to a given language to facilitate editing.

Follow these steps to sort the content of a TMX file for review.

Procedure
1. In main menu, select View → Sort Units option ([F5]) or click on the button on the top

toolbar.

The following dialog appears:
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2. Use the Sort Language drop-down to select the language used for sorting the file.

3. Select the Sort Descending check box if you want the units sorted in descending order. Clear
the check box otherwise.

4. Click the Sort Units button.

Results
All units will be sorted according to the selected language. To display all units in the original order,
reopen the dialog and click the Clear Sorting button.

Filter Units
Follow these steps to filter units containing a given text or to display untranslated units.

Procedure
1. In main menu, select View → Filter Units option ( [F3]) or click the on the top toolbar.

The following dialog appears:

2. Select what to want to filter:

• To locate and highlight a given text in the TMX file:

a. Type the text that you want to find in the Text to Search box.

b. Use the Filter Language drop-down to select the language where the search will be
performed.
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c. Select the Regular Expression box if you want to use regular expressions for
specifying the text to search.

d. Check the Case Sensitive Search box if you want to find only entries that match the
case of the entered text.

• To display untranslated units only:

a. Check the Show Untranslated Units Only box.

b. Use the Source Language drop-down to select the source language that will be used
when filtering.

3. Click the Apply Filters button.

Results
Filtering options will remain active until you reopen the Filter Units dialog and click the Clear
Filters button.

Search & Replace Text
Follow these steps perform a global search & replace operation.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Edit → Replace Text... option ([Ctrl+F] on Windows/Linux, [Cmd+F] on
macOS) or click the button on the top toolbar.

The following dialog appears:

3. Enter the text to replace in the Text to Search text box.

4. Enter the replacement text in the Replace With text box.

5. Use the Language drop-down to select the language column where the replacement should
be performed.

6. Select theRegular Expression check box if youwant to use regular expressions for specifying
the text to search

7. Click the Replace Text button.
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Results
All exact appearances of the text in Text to Search, or fragments that match the given regular
expression, are replaced with the text specified in the Replace With box.

Change Language
Follows these steps to change a language code used in a TMX file

About this task
Most TranslationMemory (TM) systems are sensitive to language codes. A TM systemmay normally
consider that the code "en" (English) is different from "en-US" (English for the United States) or
"en-GB" (English for the United Kingdom)

TMXEditor allows you to change the language codes used in a TMX file.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Tasks → Change Language... option.

The following dialog appears:

3. Use the Current Language drop-down box to select the language that you want to change.

4. Use the New Language drop-down box to select the new language code.

5. Click the Change Language button.

The dialog closes and the editing window is refreshed to reflect the changes.

Add Language
Follow these steps to add a language to a TMX file.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Tasks → Add Language... option.

The following dialog appears:
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3. Use the drop-down box to select the language to add.

4. Click the Add Language button.

The dialog closes and the editing window is refreshed to reflect the changes.

Remove Language
Follow these steps to remove a language from a TMX file.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Tasks → Remove Language... option.

The following dialog appears:

3. Use the drop-down box to select the language to remove.

4. Click the Remove Language button.

The dialog closes and the editing window is refreshed to reflect the changes.

Change Source Language
Follow the steps to change the source language of a TMX file.

About this task
Some translation memory systems use bilingual TMX files and translate in only one direction.

Use this option to select the source language of your TMX file for systems that cannot translate
in any direction.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, select Tasks → Change Source Language... option.

The following dialog appears:
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3. Use the Select Language drop-down box to select the new source language.

The Select Language drop-down control includesAny Language as first entry. Use this option
to indicate that the file can be used in any direction.

4. Click the Change Source Language button.

Remove Inline Tags
Follow these steps to remove inline tags from a TMX file.

About this task
The presence of inline tags may have an adverse effect when retrieving TM matches if a penalty
is applied for missing or differences in inline tags.

Procedure
1. Open the TMX file that you want to clean.
2. In main menu, select Tasks → Remove All Tags option.

Results
A progress dialog is displayed while inline tags are removed. The editing window is refreshed to
reflect the changes.

Remove Duplicated Units
Follow these steps to remove duplicated entries in a TMX file.

About this task
Duplicated translation units increase the size of a TMX file and slow down TM searches.

Procedure
1. Open the TMX file that you want to modify.
2. In main menu, select Tasks → Remove Duplicates option.

Results
A progress dialog is displayedwhile duplicated units are removed. The editingwindow is refreshed
to reflect the changes.

Remove Untranslated Units
Follow these steps to remove untranslated units from a TMX file.
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About this task
A translation unit that has just one <tuv> element that contains text is considered "untranslated".
Untranslated units are hardly useful for retrieving matches from a Translation Memory system.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, seect Tasks → Remove Untranslated... option.

The following dialog appears:

3. Use the Source Language drop-down to select the language to be considered language for
removing units (it may differ from the source language set at file level).

4. Click the Remove Untranslated Units button.

A progress dialog is displayed while untranslated units are removed.

Results
The editing window is refreshed to reflect the changes.

Remove Translation Same as Source
Follow these steps to remove translation entries that are the same as source entry from a TMX
file.

About this task
Translation unitsmay contain one ormore language entries that are equal to the entry designated
as source. If in a given unit all entries have the same content, this procedure removes the entire
unit. If at least one language entry is different from source, the unit is preserved containing only
translations that are different from source.

Procedure
1. Open the TMX file that you want to modify.

2. In main menu, seect Tasks → Remove Translation Same as Source... option.

The following dialog appears:
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3. Use the Source Language drop-down to select the language to be considered language for
removing units (it may differ from the source language set at file level).

4. Click the Remove Translation Same as Source button.

A progress dialog is displayed while translation enties that are equal to source are removed.

Results
The editing window is refreshed to reflect the changes.

Remove Initial & Trailing Spaces
Follow these steps to remove initial and trailing spaces from all segments of a TMX file.

About this task
Leading or trailing spaces may affect the match quality rating of matches retrieved from a
translation memory system.

Procedure
1. Open the TMX file that you want to modify.
2. In main menu, select Tasks → Remove Initial/Trailing Spaces option.

Results
A progress dialog is displayedwhile spaces are removed. The editingwindow is refreshed to reflect
the changes.

Consolidate Translation Units
Follow these steps to consolidate units in a TMX file with three or more languages.

About this task
In files with three or more languages, it is possible that translations of a given source text into
different languages appear in different translation units, as illustrated by the following image.
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Consolidating units puts all related translations in the same unit. The following image shows the
consolidated version of the one above.

Procedure
1. Open the TMX file that you want to consolidate.

2. In main menu, select Tasks → Consolidate Units... option.

The following dialog appears:

3. Use the Source Language drop-down to select the language to be considered language for
merging units (it may differ from the source language set at file level).

4. Click the Consolidate Units button.

Results
A progress indicator is displayed while units are consolidated. The editing window is refreshed to
reflect the changes.

Split TMX File
Follow these steps to split a TMX file in two or more parts.

About this task
Sometimes a TMX file may be too big to be processed and splitting it into smaller piecesmay help.

Procedure
1. In main menu, select File → Split TMX File... option.

The following dialog appears:
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2. Enter the full name of the file to split in the TMX File box or click theBrowse... button to select
the file from the file system.

3. Select the number of parts in which you want to split the file.

4. Click the Split TMX File button.

Results
A progress dialog is displayed while the selected TMX file is split into the indicated number of
smaller TMX files that are created in the same folder. The original document is left unchanged.

Merge TMX Files
Follow these steps to merge the content of two or more TMX files into a larger one.

Procedure
1. In main menu, select File → Merge TMX Files... option.

The following dialog appears:

2. Enter the full name of the file that will contain all merged data in theMerged TMX File box
or click the Browse... button to select a file from the file system.

3. Use the Add Files button to select the files to be merged from the file system.

4. If you need to remove files from the list, select them clicking the corresponding boxes in the
leftmost column and then click the Delete Selected Files button.

5. Click theMerge TMX Files button.

Results
A progress dialog is displayed while a TMX file containing data from all selected files is created in
the indicated location.
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Conversion Tasks
TMXEditor can perform the following conversions:

• Convert Excel File to TMX

• Export TMX as Excel File

• Convert CSV/TAB Delimited File to TMX

• Export TMX as TAB Delimited File

• Convert SDLTM File to TMX

Note
Prefer Excel files over CSV/TAB delimited when your data contains multiple lines of
text in a single cell or translation unit.

Convert Excel File to TMX

About this task

Procedure
1. In main menu, select File → Convert Excel File to TMX option or click the button on the

top toolbar.

The following dialog appears:

2. Type the name of the Excel file to be converted in the Excel File text field or use the associated
Browse... button to select a file from the system.
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A preview of the the initial ten rows of the first worksheet is automatically loaded when you
use the Browse... button:

3. If you typed an Excel file name on the Excel File text box, click the Refresh Preview button
to generate a preview.

4. Type the name of the TMX file to generate in the TMX File text field or use the associated
Browse... button to select a file name and location.

5. Use the Sheet drop-down control to select the worksheet that you want to convert.

6. Click the Set Languages button if language codes are not included in the file or you wish to
change the automatically detected ones.

The following dialog appears:

7. Use the drop-down selectors to associate a language to each column. Click on the Set
Languages button when finished.

The preview panel is updated to display selected languages for each column:
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8. Click the Convert Excel File to TMX button.

Results
A TMX file containing all text from the Excel document is generated in the selected location.

Export TMX as Excel File
Follow these steps to convert a TMX file to an Excel spreadsheet.

About this task
Microsoft Excel files provide a common way to exchange tabular data. TMXEditor is able to export
TMX text data, without inline tags, to .xlsx files.

Note
An Excel worksheet on Office 365 and newer versions of Microsoft Office such as
Excel 2019, 2016, 2013, 2010 and 2007 can contain maximum 1,048,576 rows and
16,384 columns. Older versions contained a limit of maximum 65,536 rows and 256
columns.

Procedure
1. Open the TMX file that you want to export.
2. In main menu, select File → Export as Excel File... option.
3. Use the dialog that appears to locate and select the generated Excel file.

Convert CSV/TAB Delimited File to TMX
Follow these steps to convert a CSV or TAB delimited file to TMX.

About this task
CSV (Comma Separated Values) are plain text files that contain text organized in tabular format,
using commas to separate columns and quotes to delimit column content.

TAB delimited files are similar to CSV, but using TAB characters to separate columns and usually
without column delimiters.

TMXEditor allows conversion to TMX of text files with different combinations of column separators
and text delimiters.
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Note
Text files exported from Microsoft Excel use these default settings:

• Character Set: UTF-16LE

• Column Separator: TAB

• Text Delimiter: none

Procedure
1. In main menu, select File → Convert CSV/TAB Delimited File to TMX option or click the

button on the top toolbar.

The following dialog appears:

2. Type the name of the file to be converted in the CSV File text field or use the associated
Browse... button to select a file from the system.

3. Type the name of the TMX file to generate in the TMX File text field or use the associated
Browse... button to select a file name and location.

4. Use the Character Set, Column Separator and Text Delimiter drop-down boxes to define
the format of the file to be converted. Use the preview panel to check the correctness of the
selected settings. Use Custom Separator and Custom Delimiter text boxes to enter values
not included in the drop-down selectors.

19Conversion Tasks



On success, the preview panel displays the data in a tabular format. If language codes are
included in the first row of the CSV file, they will be automatically detected and will also be
displayed highlighted in the panel, as shown in this picture:

Troubleshooting

Unexpected characters, like the ones shown in the picture below, indicate wrong character
set selection.

Readable text that is not displayed as a table, is a sign of incorrect selection of column separator
or text delimiter. Use the preview panel to check the correct values.

5. Click the Set Languages button if language codes are not included in the file or you wish to
change the automatically detected ones.

The following dialog appears:
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6. Use the drop-down controls in the CSV/Text Languages dialog to select the languages in the
CSV file. Click the Set Languages button to confirm your selection.

7. Check the Fix Excel Double Quotes box if the file was exported by Excel using double quote
characters as text delimiter. This option ensures that quotes are not duplicated during
conversion.

8. Check the Optional Text Delimiters box if the file does not use the selected text delimiter in
all cases (some tools only surround text in delimiters when the de column separator is part
of the exported text).

9. Finally, click the Convert CSV to TMX button to generate the TMX file.

Results
The CSV file is converted to TMX and automatically opened in the editor if the Open Generated
TMX File check box is selected.

Export as TAB Delimited File
Follow these steps to convert a TMX file to TAB delimited format that can be reviewed using
Microsoft Excel or similar applications.

About this task
Tab-delimited files are plain text files used for storing data in a tabular structure, e.g., database
table or spreadsheet data, and a way of exchanging information between databases. Each record
in the table is one line of the text file and entries are separateed by a TAB character.

Procedure
1. Open the TMX file that you want to export.
2. In main menu, select File → Export as TAB Delimited File... option.
3. Use the dialog that appears to locate and select the file where to save the TAB delimited

version.

Results
A progress indicator is displayed while the file is exported as TAB delimited using Microsoft Excel
standard settings (UTF-16LE character set, TAB as column separator and no text delimiters).
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Convert SDLTM File to TMX

About this task

Procedure
1. In main menu, select File → Convert SDLTM File to TMX option or click the button on the

top toolbar.

The following dialog appears:

2. Type the name of the SDLTM file to be converted in the SDLTM File text field or use the
associated Browse... button to select a file from the system.

3. Type the name of the TMX file to generate in the TMX File text field or use the associated
Browse... button to select a file name and location.

4. Click the Convert SDLTM File to TMX button.

Results
The SDLTM file is converted to TMX and automatically opened in the editor if theOpenGenerated
TMX File check box is selected.
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TMX Validation

About this task
Most CAT (Computer Aided Translation) tools rely on TMX (TranslationMemory eXchange) standard
to exchange translation memory data. Unfortunately, some tools produce files that are not valid
and others do not accept TMX documents that are correctly formatted.

TMXEditor checks the validity of TMX files against TMX DTD and also verifies if they follow the
requirements described in TMX specifications.

Procedure
1. In Filemenu, select the Validate TMX File... option.

2. Use the dialog that appears to locate and select the file that you want to validate.

A progress dialog is displayed while the file is analyzed.

Results
After checking the TMX file, a dialog with validation results appears.

Clean Invalid Characters
Follow these steps to remove invalid characters from a TMX file.

About this task
TMX is an XML-based vocabulary and thereafter a TMX filemust not contain characters not allowed
by the XML standard.

A TMX file that contains invalid characters cannot be edited without removing those characters
first.

Procedure
1. In main menu, select File → Clean Invalid Characters... option.

2. Use the dialog that appears to locate and select the file that you want to repair.

Results
A progress indicator is displayed while the selected file is cleaned and a backup of the original
data is saved in the same folder.
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Program Settings

Procedure
1. Open the preferences dialog:

• On Windows or Linux menu, select Settings → Preferences option.

• On macOS main menu, select TMXEditor → Preferences... → Settings option.

The following dialog appears:

2. Use the Theme drop-down to select the colors used in the graphical user interface. Available
options are:

• System Default: automatically selects Dark or Light colors according to the preferences
set in the operating system.

• Dark: Uses dark background with white text.

• Light: Uses light grey background with dark text

3. Use theMax File Size for Memory Storage (MB) drop-down to indicate the maximum size
on disk of a TMX file to edit using memory. Files with disk size larger than the selected option
are stored in a database while editing.

Note:To store a TMX file in memory requires approximately six times the size the file has on
disk. If a TMX file uses 200MB of disk space, reading and storing it in memory may require
approximately 1.2GB of RAM.

4. Select the number of spaces used to indent XML elements in the TMX file using the Indentation
selector.

Note: Indentation helps in visually understanding the structure of an XML file when viewing
it as plain text but is not required for processing TMX files with translation tools.

5. Click the Save Preferences button to save and activate selected settings.

Results
Theme changes are adopted immediately. Memory usage settings are applied when a new TMX
file is opened. Indentation is applied next time a file is saved.
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Subscriptions
TMXEditor is available in two modes:

• Source Code

• Yearly Subscriptions for installers and support

Source Code
Source code of TMXEditor is free. Anyone can download the source code fromGithub.com, compile,
modify and use it at no cost in compliance with the accompanying license terms.

Subscriptions
Ready to use installers and technical support for TMXEditor are available as yearly subscriptions
at Maxprograms Online Store.

The version of TMXEditor included in the official installers can be used at no cost for 7 days
requesting a free Evaluation Key.

Subscription Keys cannot be shared or transferred to different machines.

Differences Summary

Subscription BasedSource Code

YesNoReady To Use
Installers

YesNoNotarized macOS
launcher

YesNoSigned launcher and
installer forWindows

YesNoAssociate app with
.tmx extension on
WindowsandmacOS

NoneNoneRestricted Features

Technical Support • Direct email at
tech@maxprograms.com

• Peer support at Groups.io

• Peer support at Groups.io

First Registration - Evaluation Request

Procedure
1. When you open TMXEditor from subscription installers for the first time, or when the

Subscription Key is not registered, the following dialog is displayed:
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2. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.

On registration success, the main editing screen will be presented.

3. If you don't have a Subscription Key and wish to test the program during 7 days, click the
Request Evaluation Key button.

The following dialog appears:

4. Enter the requested data and click the Request Evaluation Key button.

On success, an email with the requested Evaluation Key will be sent to the indicated address
and the following dialog will be displayed:

Check your email and register the Evaluation Key using the instructions shown above.

Subscription Renewal

About this task
You can register a new subscription key before your existing subscription expires.
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Procedure
1. In Helpmenu, select Register Subscription... option.

The following dialog appears:

2. If you don't have a subscription key yet, click on the Purchase Subscription button to open
Maxprograms Online Store on your internet browser.

3. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.

On registration success, The following dialog appears:
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Licenses
TMXEditor uses components from these open source projects:

DTDParser

• Formerly available from http://wutka.com/dtdparser.html

• Published under two licenses: Apache Style License and LGPL 2.1

Electron

• Available from https://www.electronjs.org/

• Published under MIT License

Java

• Available from https://adoptium.net/

• Published under GPL with CLASSPATH Exception

JSON-java

• Available from https://github.com/stleary/JSON-java

• Published under a custom license

jsoup

• Available from https://jsoup.org

• Published under MIT License

MapDB

• Available from https://mapdb.org

• Published under Apache License

OpenXLIFF Filters

• Available from https://www.maxprograms.com/products/openxliff.html

• Published under Eclipse Public License 1.0

sdltm

• Available from https://github.com/rmraya/sdltm

• Published under Eclipse Public License 1.0

TMXValidator

• Available from https://www.maxprograms.com/products/tmxvalidator.html

• Published under Eclipse Public License 1.0

XMLJava

• Available from https://github.com/rmraya/XMLJava

• Published under Eclipse Public License 1.0
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http://wutka.com/dtdparser.html
https://raw.githubusercontent.com/rmraya/OpenXLIFF/master/licenses/dtd/ASL_LICENSE
https://raw.githubusercontent.com/rmraya/OpenXLIFF/master/licenses/dtd/LICENSE
https://www.electronjs.org/
https://raw.githubusercontent.com/electron/electron/main/LICENSE
https://adoptium.net/
https://raw.githubusercontent.com/adoptium/jdk/master/LICENSE
https://github.com/stleary/JSON-java
https://raw.githubusercontent.com/rmraya/OpenXLIFF/master/licenses/json/LICENSE
https://jsoup.org/
https://raw.githubusercontent.com/rmraya/OpenXLIFF/master/licenses/jsoup/LICENSE
https://mapdb.org/
https://raw.githubusercontent.com/rmraya/OpenXLIFF/master/licenses/mapdb/LICENSE
https://www.maxprograms.com/products/openxliff.html
https://www.eclipse.org/org/documents/epl-v10.html
https://github.com/rmraya/sdltm
https://www.eclipse.org/org/documents/epl-v10.html
https://www.maxprograms.com/products/tmxvalidator.html
https://www.eclipse.org/org/documents/epl-v10.html
https://github.com/rmraya/XMLJava
https://www.eclipse.org/org/documents/epl-v10.html


Glossary
Character Set

A character set (sometimes referred to as code page) is a collection of characters that are
associated with a sequence of natural numbers in order to facilitate the storage of text
in computers and the transmission of text through telecommunication networks.

Language Code
A language code is a code that assigns letters or numbers as identifiers or classifiers for
languages. Language codes used in TMX files must comply with the rules defined by BCP
47 - Tags for Identifying Languages

Subscription Key
A Subscription key is a short text code that lets you register and use a software program
during a pre-established time period.

TMX
Translation Memory eXchange (TMX) is an open standard originally published by LISA
(Localization Industry Standards Association). The purpose of TMX is to allow easier
exchange of translationmemory data between tools and/or translation vendors with little
or no loss of critical data during the process.

Source Language
The language of a document that is to be translated.

Translation Memory
TranslationMemory (TM) is a language technology that enables the translation of segments
(paragraphs, sentences or phrases) of documents by searching for similar segments in
a database and suggesting matches that are found in the databases as possible
translations.

Translation Unit
A translation unit (represented by the <tu> element in a TMX file) contains a piece of
source text and optional translation and metadata related to that piece of text.

i

https://tools.ietf.org/html/bcp47
https://tools.ietf.org/html/bcp47
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