Stingray User Guide

Copyright © 2008 - 2022 Maxprograms

Stingray User Guide

Table of Contents
Introduction ................................................................................................................................... 1
Supported File Formats ................................................................................................................... 1
Supported Platforms ....................................................................................................................... 2
Getting Started .............................................................................................................................. 3
Step 1: Create Alignment File ......................................................................................................... 3
Step 2: Align extracted segments .................................................................................................. 4
Step 3: Export aligned segments ................................................................................................... 5
Export as TMX ........................................................................................................................... 6
Export as TAB Delimited .......................................................................................................... 6
Program Settings .......................................................................................................................... 7
Subscriptions ................................................................................................................................. 8
First Registration - Evaluation Request ......................................................................................... 8
Subscription Renewal .................................................................................................................... 10

i

Stingray User Guide

Introduction
Stingray is a cross-platform document aligner designed to assist professional translators in the
production of translation memories from existing translated material.
Translation memories in TMX format generated by Stingray can be used in most modern CAT
(Computer Aided Translation) tools, including Swordfish.
The following image shows Stingray User Interface:

Supported File Formats
The file formats currently supported by Stingray are:
General Documentation Types

Software Development Types

• Adobe InCopy ICML

• JavaScript

• Adobe InDesign Interchange (INX)

• Java Properties

• Adobe InDesign IDML CS4, CS5, CS6 & CC

• JSON

• HTML

• RC (Windows C/C++ Resources)

• Microsoft Office

• ResX (Windows .NET Resources)

• Microsoft Visio XML Drawings
• MIF (Maker Interchange Format)
• OpenOffice/LibreOffice/StarOffice
• Plain Text
• SRT Subtitles
• XML (Generic)
• XML with ready to use configuration files for:
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General Documentation Types

Software Development Types

– DITA 1.0, 1.1, 1.2 and 1.3
– DocBook 3.x, 4.x and 5.x
– SVG
– Word 2003 ML
– XHTML
The filter for XML files supports custom configuration. Users can define conversion rules for almost
any XML vocabulary.

Supported Platforms
Stingray works on these Operating Systems:
• Microsoft Windows (8, 8.1, 10 and 11)
• macOS High Sierra (10.13), Mojave (10.14), Catalina (10.15), Big Sur (11.0) and Monterey (12.0)
• Linux (with GNOME Desktop Manager)
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Getting Started
Aligning is a process with 3 basic steps:
1. Create an alignment file, selecting the documents to align.
2. Correct the alignment of the generated/imported segment pairs.
3. Export the aligned segments to a useful file format.

Step 1: Create Alignment File
Alignment work is performed on an slignment file, a special file created from a document and its
translation.

Procedure
1. In main menu, select File → New Alignment ([Ctrl+N] on Windows/Linux, [Cmd+N] on macOS)
or click the button on the main toolbar.
The following dialog appears:

2. Enter the name of the alignment file in the Alignment File text box or use the Browse...
button next to it to select a name and location.
3. Select a source file and configure its properties in the left panel.
a. Type the name of the source file in the Source File text box or use the Browse... button
next to it to select a file from the operating system. When you use the Browse... button,
the programs tries to automatically detect document type and character set.
b. Select or correct the type of document in the File Type drop-down list.
c. Select or correct the character set of the document in the Character Set drop-down list.
4. Select the file that contains the translations and configure its properties in the right panel.
a. Type the name of the translation file in the Target File text box or use the Browse...
button next to it to select a file from the operating system. When you use the Browse...
button, the programs tries to automatically detect document type and character set.
b. Select or correct the type of document in the File Type drop-down list.
c. Select or correct the character set of the document in the Character Set drop-down list.
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5. Check the Paragraph Segmentation box if you want to align paragraphs instead of sentences.
6. Click the Align Files button to create the alignment file and display it in Stingray's main panel.

Step 2: Align extracted segments
Use these options to correct alignment errors when necessary
• Use the buttons that appear on the main toolbar, or their equivalent entries from the Edit
menu, to correct the segments.
– To edit the content of the source or translation text box, click on a cell and modify its text.
Save your changes with the Confirm Edit button ( ) or discard them using the Cancel
Edit button ( ).
– Use the Replace Text button ( ) to replace text anywhere in the document using the
Replace Text dialog.

– Use the Move Segment Down ( ) and Move Segment Up ( ) buttons to move a selected
cell up and down until it matches the corresponding source/translation in the other
column.
– If you need to split the text in a source or target cell to match the counterpart in the
other column, click on the cell and put the cursor where you want the division to happen.
Finally, click on the the Split Segment button ( ) .
– Use the Merge with Next Segment button ( ) to combine the text on a selected source
or translation cell with the text of the following segment.
– Use the Remove Segment button ( ) to delete the selected source or translation cell.
– Use the Remove Tags button ( ) to remove inline tags from all segments at once.
– Use the Remove Duplicates button ( ) to remove all duplicate entries at once.
– Use the Change Languages button ( ) to modify the languages in your file using the
the Change Languages dialog.
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• Use these keyboard shortcuts for faster editing. On macOS replace 'Ctrl' with 'Cmd' and 'Alt'
with 'Option'.
Button

Keyboard Shortcut

Action

Ctrl+F

Opens the Replace Text dialog

Alt+Enter

Confirm Edit

Escape

Cancel Edit

Alt+Ctrl+Down Arrow

Move Segment Down

Alt+Ctrl+Up Arrow

Move Segment Up

Ctrl+L

Split Segment

Ctrl+M

Merge with Next Segment

Ctrl+D

Remove Segment

Ctrl+X

Cut

Ctrl+C

Copy

Ctrl+V

Paste

Ctrl+A

Select All

• Use the buttons that appear on the bottom toolbar, or their equivalent entries from the View
menu, to naviagate the pages that comprise your document. On macOS replace 'Ctrl' with
'Cmd' in the keyboard shortcuts.
Button

Keyboard Shortcut

Action

Ctrl+Home

First Page

Ctrl+Page Up

Previous Page

Ctrl+Page Down

Next Page

Ctrl+End

Last Page

Step 3: Export aligned segments
Stingray can export aligned segments in these formats accepted by most translation tools:
• TMX 1.4
• TAB Delimited
TAB delimited files exported by Stingray can be directly opened, whithout any special configuration,
by Microsoft Excel or Apple Numbers.
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Export as TMX
Procedure
1. In main menu, select File → Open Alignment ([Ctrol+O] on Windows/Linux, [Cmd+O] on macOS)
or click the button.
2. Use the dialog from the Operating System that appears to locate and open the alignment file
that you want to export.
3. In main menu, select File → Export Alignment as TMX or click the button.
4. Select a file name and location for storing the generated TMX file.

Results
A TMX file is generated and saved in the selected location.

Export as TAB Delimited
Procedure
1. In main menu, select File → Open Alignment ([Ctrol+O] on Windows/Linux, [Cmd+O] on macOS)
or click the button.
2. Use the dialog from the Operating System that appears to locate and open the alignment file
that you want to export.
3. In main menu, select File → Export Alignment as TAB Delimited or click the button.
4. Select the file to generate.

Results
A TAB delimited text file is created and saved in the selected location.

Getting Started
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Program Settings
Procedure
1.

• On macOS, select Apple → Preferences → Settings on the menu or press [Cmd + ,].
• On Windows or Linux main menu, select Settings → Preferences.
The following dialog appears:

2. Use the Default Source Language and Default Target Language drop-down selectors to
define the languages that Stingray will use as default when creating an alignment file.
3. If you prefer to do segmentation using a custom set of SRX rules, enter the path of the SRX
file in the Default SRX File text box or use the Browse... button next to it to select a file from
the file system.
4. If you align custom XML files that require an XML catalog, enter the path to your catalog in
the Default Catalog text box or use the Browse... button next to it to select a catalog file
from the file system.
5. Use the Theme drop-down to select the colors used in the graphical user interface. Available
options are:
• System Default: automatically selects Dark or Light colors according to the preferences
set in the operating system.
• Dark: Uses dark background with white text.
• Light: Uses light grey background with dark text
6. Click the Save Preferences button to save and activate selected settings.

Results
Theme changes are adopted immediately. All other settings are applied the next time an alignment
file is created.

Program Settings
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Subscriptions
Stingray is available in two modes:
• Source Code
• Yearly Subscriptions for installers and support

Source Code
Source code of Stingray is free. Anyone can download the source code from Github.com, compile,
modify and use it at no cost in compliance with the accompanying license terms.

Subscriptions
Ready to use installers and technical support for Stingray are available as yearly subscriptions at
Maxprograms Online Store.
The version of Stingray included in the official installers can be used at no cost for 7 days requesting
a free Evaluation Key.
Subscription Keys cannot be shared or transferred to a different machine.

Differences Summary
Source Code

Subscription Based

Ready To Use Installers

No

Yes

Notarized macOS
launcher and installer

No

Yes

Signed launcher and
installer for Windows

No

Yes

Associate app with
.algn extension on
Windows and macOS

No

Yes

Restricted Features

None

None

Technical Support

• Peer support at Groups.io

• Direct email at tech@maxprograms.com
• Peer support at Groups.io

First Registration - Evaluation Request
Procedure
1. When you open Stingray from subscription installers for the first time, or when the Subscription
Key is not registered, the following dialog is displayed:

Subscriptions
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2. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.
On registration success, the main editing screen will be presented.
3. If you don't have a Subscription Key and wish to test the program during 7 days, click the
Request Evaluation Key button.
The following dialog appears:

4. Enter the requested data and click the Request Evaluation Key button.
On success, an email with the requested Evaluation Key will be sent to the indicated address
and the following dialog will be displayed:

Check your email and register the Evaluation Key using the instructions shown above.

Subscriptions
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Subscription Renewal
About this task
You can register a new subscription key before your existing subscription expires.

Procedure
1. In Help menu, select Register Subscription... option.
The following dialog appears:

2. If you don't have a subscription key yet, click on the Purchase Subscription button to open
Maxprograms Online Store on your internet browser.
3. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.
On registration success, the following dialog appears:

Subscriptions
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Glossary
Computer Aided Translation (CAT)
Computer technology application designed to assist human translators in the translation
process.
Character Set
A character set (sometimes referred to as code page) is a collection of characters that are
associated with a sequence of natural numbers in order to facilitate the storage of text
in computers and the transmission of text through telecommunication networks.
CSV
SRX

TMX

CSV (Comma Separated Values) is a standard file format used to store tabular data.
Segmentation Rules eXchange (SRX) is an XML-based open standard, published by LISA
(Localization Industry Standards Association), for describing how translation and other
language-processing tools segment text for processing.
Translation Memory eXchange (TMX) is an open standard originally published by LISA
(Localization Industry Standards Association). The purpose of TMX is to allow easier exchange of translation memory data between tools and/or translation vendors with little
or no loss of critical data during the process.

Translation Memory
Translation Memory (TM) is a language technology that enables the translation of segments
(paragraphs, sentences or phrases) of documents by searching for similar segments in
a database and suggesting matches that are found in the databases as possible translations.
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